Livespace - We're Working to Restore All Livespace Services – Incident details

All systems operational

We're Working to Restore All Livespace Services

Resolved
Major outage
Started about 1 month agoLasted 1 minute

Affected

Livespace app

Major outage from 12:14 PM to 12:15 PM

Log-in

Major outage from 12:14 PM to 12:15 PM

Updates
  • Resolved
    Resolved

    We've successfully restored all Livespace systems! You should now be able to log in and use all features normally.

    We know this outage has likely caused significant disruption to your work, and we're truly sorry for letting you down. We've learned from this incident and we're implementing measures to prevent similar issues in the future. Thank you for your incredible patience and for trusting us with your business. If you need any assistance getting back on track, please don't hesitate to reach out.

  • Investigating
    Investigating

    We're experiencing a system-wide issue affecting multiple services. You might have trouble logging in or accessing various features.

    We know you rely on Livespace for your work, and right now, we're not meeting your needs. We understand how frustrating this is, and we have our entire team focused on bringing everything back online. We appreciate your patience and we'll keep you informed at every stage.