Scheduled for Jul 05 2024 at 9:00 PM – 10:30 PM
Affects
Livespace app
Under maintenance from 9:00 PM to 10:30 PM
Log-in
Under maintenance from 9:00 PM to 10:30 PM
Completed
Jul 05 2024 at 10:30 PMCompleted
Jul 05 2024 at 10:30 PMMaintenance has completed successfully.
In progress
Jul 05 2024 at 9:00 PMIn progress
Jul 05 2024 at 9:00 PMMaintenance is now in progress.